XenoBot Forums - Powered by vBulletin

User Tag List

Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: How to add OT creature corpses to Xenobot!

  1. #11

    Join Date
    Apr 2015
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Também segui todos os passos acima, e não consegui sucesso.

    No meu caso é otserv, monstro Stone Colossus e quando ele morre vira Stone Golem, identifiquei os id dos corpos 6005,4133.4134.4135.4136, adicionei nos últimos três
    arquivos, fechei o tibia, xenobot, reiniciei o computador e mesmo assim não funcionou.


    Desde já agradeço a boa vontade em querer ajudar.


    ---- Google Translator ----

    Also follow all the steps above, and you can not succeed.
    In my case is OTServ, monster Stone Colossus and when he dies turns Stone Golem, identified the id of the corpses 6005, 4133. 4134. 4135. 4136, added the last three
    files, closed the tibia, xenobot, restarted the notebook and still not worked.
    I thank the willingness to want to help.
    ---------------------------------------

    Obrigado /Thanks
    Last edited by aureliodutr; 10-17-2015 at 03:55 AM.

  2. #12
    detmer92's Avatar
    Join Date
    May 2013
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have noticed something. I tryed to add a Ancient dragon custom id to Archlight OT. What i did i added the most freshest loot 5984, then second freshest loot 4092. And 4092 are for normal Dragon Lords. So i checked how long does it take for the corpse to change to 4092. And it only took like 7 seconds. So my guy only looted the Ancient dragon when there were only one moob couse when the corpse changed to second freshest corpse(4092) then he ignored it. So i am wondering if there is a way to make the character loot the ancient dragon(5984) instantly??

  3. #13

    Join Date
    Jun 2017
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    works perfectly to me ! thanks.

    Just follow the steps.

  4. #14

    Join Date
    Sep 2017
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It worked for me! I went one step further and added the info on every single file and now it runs smooth and without any problem.

    Thank you very much!

  5. #15

    Join Date
    Aug 2017
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Having issues with getting this working. So in my example here I've tried to add behemoth to the list (Fresh ID = 4112, decayed = 4113). I added <item id="4112"/> (and 4113) under <itemtype name="corpses"> to the 3 most recent it.blah.blah.xml files in the dir\Data folder while Tibia and Xeno were closed, and it still won't loot the custom behemoth monsters. I took it further and added them into every config xml file and still nothing. Not sure if I'm missing something horribly obvious but I've followed the steps and the video (Except my system can save the "." and directly into the Data folder) and I've checked to make sure the changes are saved into the config files.


    edit: I've tried several other monsters and I cannot get it to work on any of them, making sure I got the item ID that appears with the first second or two of the kill and the IDs that it changes to after. I've also tried adding/removing the "skin" option for applicable monsters and no change.
    Last edited by SnailMasta; 09-28-2017 at 11:44 PM. Reason: More info

  6. #16

    Join Date
    Dec 2019
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by evultoad View Post
    Update: Made a really quick video showing the process https://youtu.be/Vi3n1MqJohk
    Information how to do this is scattered around the forum, so I thought I'd make a simple guide in one place with all the information that you need.

    Ill warn you now, if you delete anything that your not supposed to in any of these files, you WILL affect the way the Xeno works and possibly break it. So follow these steps EXACTLY!

    Step 1: Locate your Xenobot install directory. In this example we will use mine, which MAY be different to yours. In this you will need to open the Data folder.
    C:\Program Files (x86)\XenoBot\Data

    Step 2: Find the your 3 latest files similar to these highlighted files. Remember that these were the three latest at time of making this guide and if its been updated yours may be different
    Attachment 12627
    it.0020.14.11.19.899.xml
    it.0021.14.11.19.941.xml
    it.0022.14.11.19.962.xml

    Step 3: Copy these three files to a new folder on your desktop

    Step 4: Find the ID of the corpses you wish to add (enable look ID's in xenobot Tools) in this case we will use a cyclops drone:
    Attachment 12629
    17:26 You see a dead cyclops (Vol:10). [ID 772]

    Step 5:So from this we know that we need to add the line
    xml code:
    <item id="772"/>

    to each of your three files in your new desktop folder under the xml code:
    <itemtype name="corpses">
    section

    example of finished file:
    Attachment 12630

    Now saving these files in the current naming will throw out an error in most cases as windows doesnt like people using "." dots in their names.
    save each file replacing all "." with "_"
    example:
    it.0020.14.11.19.899.xml
    becomes
    it.0020_14_11_19_899.xml

    you can then delete the old file (The one with .'s in it) and rename the it.
    0020_14_11_19_899.xml file to look like it.0020.14.11.19.899.xml

    So for a recap:
    • You copy the files from the Data folder to a new folder on your desktop.
    • open them
    • add the corpse ID's.
    • Save the file with _ replacing the .'s.
    • Delete the old file (in your desktop folder)
    • rename the _ files to have .'s instead
    • then copy + replace these new files into your data folder


    Found it really hard making the last part sound as simple as it is. If anyone needs more clarification please let me know.

    EDIT: Please note, I copied the files to a desktop folder as my system would not let me save them directly to the xenobot folder. It may be easier to try and save there first to save alot of hassel. Otherwise if like my system you cant save there, follow my instructions in their entirety.
    EDIT2: Everytime Xeno updates, you need to update the newly created config file!
    okokokok

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •