PDA

View Full Version : [Tutorial] How to open a .XBST or .LUA file.



Elvang
05-08-2012, 04:11 AM
.XBST
.XBST files are used to save any settings found within the game including the targeter, looter, walker, and other such things such as advertisements, HUD information, and Support.

Method 1: Loading from In-game
Step 1: Make sure the file is located in the Settings folder found here: "C:\Users\'Your-username'\Documents\Xenobot\Settings"
Step 2: Open Xenobot and login to Tibia
Step 3: Right click on yourself and select the "settings" option second from the bottom.
Step 4: Use the right and left arrow to cycle through the list of scripts found in the above location, select your script.
Step 5: Under the load section either load all settings by selecting all and hitting yes to the new menu, or select the individual parts you would like to use.

Method 2: Loading from any Location
Step 1: Open Xenobot, inject and log in to tibia.
Step 2: Double click on the .XBST file and a menu will appear in which you can select which character/client the settings file should be added to.
Step 3: Hit the 'Load Settings' button.

.LUA
.LUA files are the scripting files used for added functionality to the bot such as door opening, depositers, and refilling on supplies.

Step 1: Make sure the .LUA file is located in the Scripts folder found here: "C:\Users\'Your-username'\Documents\Xenobot\Scripts"
Step 2: Open Xenobot, inject and log in to tibia.
Step 3: Right click on yourself and select "Scripter" found at the bottom.
Step 4: Select the script you want to use and hit "Execute Script" if you would like to stop a script hit "Kill Script"

Demonoak12
05-11-2012, 11:56 AM
Thanks helped me alot =]

Khazer
05-13-2012, 09:38 PM
Thanks, i just started tibia again and this was the main bot everyone talked about so i went ahead and got a sub to try it out.

Y2Quake
05-13-2012, 09:45 PM
useful tutorials bro, since there's a lot of ppl asking.

Dark Soul
05-13-2012, 11:11 PM
Sweet. The .xbst had me so confused because on a larva script I got, the gold depositor would not work and thats cuz I just double clicked the icon when I downloaded it. Instead you have to do what you mentioned for it to work correctly. As for the .lua, I wrestled it for a while till common since kicked into gear. But +1 thumbs up on the guide!!

Hanzi
05-15-2012, 09:07 AM
thanks alot!

Palizinhu
05-15-2012, 10:25 PM
Very usefull for newcomers!

strumpaa
05-16-2012, 03:08 AM
THANK YOU ALLLOOT!

Davulo
06-19-2012, 05:42 AM
I hope this gets stickied, many newbies here (counting me).
Thanks OP. Rated *5

loganpaul
07-06-2012, 03:31 AM
[XenoScript] [Mage] Dragons Edron.lua: No such file or directory

swepwn
07-06-2012, 10:11 AM
When u save the luafile, what should you save it as? I mean what program should you save it as, when you put it in the xenobot script folder.

sakruin
02-08-2013, 04:09 PM
My xenobot folder doesn't have "script" or "settings" folder... should I create???? help plx

Elvang
02-08-2013, 07:37 PM
My xenobot folder doesn't have "script" or "settings" folder... should I create???? help plx

When you run xenobot for the first time, the folders will be created.

tristan22
03-14-2013, 01:27 AM
This helped a lot but when I try to run the script it keeps saying file cannot be opened no such file or directory

drax
06-06-2013, 12:41 AM
the .XBST part worked fine for me, But when I try loading a .LUA by right clicking and going to 'scripter', nothing is there. I've tried to 'refresh list' numerous times and it still doesn't work. please help?!

ponyo
07-15-2013, 11:03 PM
Very usefull to newcomers! Thanks

Elvang
07-17-2013, 09:45 PM
the .XBST part worked fine for me, But when I try loading a .LUA by right clicking and going to 'scripter', nothing is there. I've tried to 'refresh list' numerous times and it still doesn't work. please help?!

Your script isn't in the folder, or it has a different file extension and xenobot can't find it.

kimpan1337
10-06-2013, 06:44 PM
Good job, lovely to see that you are taking ur time to learn other people!

smudger666
10-17-2013, 03:23 PM
i have my lua files in scripts but if i press execute it come up with "XenoScript Error:
Script: Edron-EarthElemental?Mage?.lua
Error: cannot open C:?Users?lewis?Documents?XenoBot?Scripts?Forgee.lu a: No such file or directory
This is an error with user-input and should not be reported as a bug with XenoBot." any help?

mingfan
03-16-2014, 04:37 PM
When you run xenobot for the first time, the folders will be created.

There isn't a Script file in my xenobot files and the bot doesnt detect the lua files

Elvang
03-21-2014, 05:58 PM
There isn't a Script file in my xenobot files and the bot doesnt detect the lua files

The folders will be created not any scripts or anything. You have to put those in the folders yourself.

Killah D
05-09-2014, 03:55 PM
My xeno folder doesn't have a settings file apparently<<<<<<<<<<<<<<<<<<<<<<<<<<<Figured it out I cant run it as admin also it tells me theres no xbst file I dled it and it didn't come with one the script is shit then?

Elvang
05-09-2014, 04:21 PM
My xeno folder doesn't have a settings file apparently<<<<<<<<<<<<<<<<<<<<<<<<<<<Figured it out I cant run it as admin also it tells me theres no xbst file I dled it and it didn't come with one the script is shit then?

I guess so?

Killah D
05-09-2014, 04:34 PM
Im adding u on Skype can u Skype with me so I can explain my problem and u can try to help?

Killah D
05-09-2014, 05:16 PM
Thanks for helping Elvang!! really helped me get started on this new bot!!

WafflingFlyer6
05-11-2014, 04:20 PM
i have my lua files in scripts but if i press execute it come up with "XenoScript Error:
Script: Edron-EarthElemental?Mage?.lua
Error: cannot open C:?Users?lewis?Documents?XenoBot?Scripts?Forgee.lu a: No such file or directory
This is an error with user-input and should not be reported as a bug with XenoBot." any help?


I am having this same problem but i noticed no1 replied with a solution?

Any help would be greatly appreciated