PDA

View Full Version : Targetting malfunction



Delejon
05-03-2012, 09:20 PM
Hey!

I have set the targetting to cast spell when there is 1-2 monsters and when there is a 3rd it will use SD however this never happens. I would assume it is because the targetting only works properly if all the 3 monsters are visible to you, and by visible I mean that they are visible from the start. E.g. if you have 2 monsters on you it will cast a spell to attack but if a 3rd enters the picture it is supposed to SD but it doesn't.

I tried making myself clear but it's kind of hard explaining this situation. To put it simple I want the targetting to decide attack mode depending on how many are currently on the screen always even if one appears a bit later, at that point it should switch attack mode from spell to SD.

Thanks!

youonlyliveonce
05-04-2012, 11:59 AM
This would be similar to the "Stick" function from Neobot I think? Makes sense, bot initially registers only 2 of the creature, so it attacks accordingly. If a third comes on the screen, the bot stays "stuck" on the 2 monster setting as opposed to switching to the 3 monster setting (in your case, SD). Correct me if I'm wrong.

I'd support that for sure, although it seems like it could be a tricky implementation... could be wrong.

Delejon
05-04-2012, 12:29 PM
Yeah mate you got it perfectly right :)

DarkstaR
05-04-2012, 12:58 PM
I'll add it to the ToDo list. I actually noticed it when botting dragons :P

Delejon
05-04-2012, 01:15 PM
I'll add it to the ToDo list. I actually noticed it when botting dragons :P

Thanks for the quick response, sounds good. :)

rikardo
05-06-2012, 11:40 PM
This really is an excellent feature because I've died 4x to Dragon because of this, at first just a dragon, and after a few seconds and others arise xenobot is configured to run when you have 3 + dragons but he understands that there is only one, until kill this and can recalculate how many monsters there on the screen.
Good suggestion that would help a lot.